Pages

Monday, May 18, 2009

Trail Run Today

Since my Alpine Cross shoes were still drying on the porch, I wore my Mizuno Wave Ascends. I had replaced the original insoles with some 'moldable' ones from Walmart. Well, the Mizunos got wet (duh) and I pulled the insoles out to dry. When I attempted to put them back in, it didn't really work. So I ran with no insoles, which answered the question for me "do you really need insoles"? My feet slid quite a bit in these.

I also took a header not more than 1/4 quarter up the trail. I slipped on some slick muddy leaves, and took a nice tumble. Haven't done that in quite a while.

About two miles in, I noticed my knee hurting. It was the same twinge I had during my run with Luc on Sunday. I can't quite describe it well, except it was on the inside of my left knee. All my normal aches and pains occur on my right leg, the left one hurting was new to me. By the end of the run, it was also hurting on the downhill.



So I don't know if I am just having pyschosomatic pain before the big Mohican training weekend. It's not like I have dialed up my running. I think it's just one of these niggling little pains to give me something to worry about.



This shoe sucking mud pic isn't from today, I just noticed it on the computer and found it funny and wanted to repost it.

3 comments:

  1. Great report Kim
    Looking forward to seeing you this weekend. --Mark Carroll

    ReplyDelete
  2. Hey Kim, it was 107 today!!! YUK, would much rather have that mud!!
    Debbie

    ReplyDelete
  3. Hope your knee twinge is nothing! All my injury haunts are on the right side also, so it must be nothing since it's on the left. Good luck on your big weekend.

    ReplyDelete

I would love to hear from you!